mysql升格后php无法使用

  • 内容
  • 评论
  • 相关

mysql升级后php无法使用
mysql用jason的源后,虽然可以直接yum到5.5了,但是php-mysql无法使用了
总是无法update到对应的依赖包。
错误如下:

欢迎大家阅读《mysql升格后php无法使用》,跪求各位点评,by 搞代码

谷歌了好久,得到的方案是,把php和mysql相关的都删除了,然后切换一个源,重新安装php和mysql
删除php内容

rpm -qa|grep mysql
rpm -qa|grep php
把看到的内容都删除了
yum remove php-*
yum remove mysql
yum erase mysql-libs

切换源
rpm -Uvh http://rpms.famillecollet.com/enterprise/remi-release-5.rpm
安装mysql
yum --enablerepo=remi,remi-test install mysql mysql-server
yum --enablerepo=remi,remi-test install php
yum --enablerepo=remi,remi-test install php-mysql

终于再也没看到那个可恶的包依赖了。

原创文章,转载请注明: 转载自搞代码

本文链接地址: mysql升格后php无法使用

微信支付二维码

微信 赏一包辣条吧~

支付宝支付二维码

支付宝 赏一听可乐吧~

评论

0条评论

发表评论

电子邮件地址不会被公开。 必填项已用*标注