• 欢迎访问搞代码网站,推荐使用最新版火狐浏览器和Chrome浏览器访问本网站!
  • 如果您觉得本站非常有看点,那么赶紧使用Ctrl+D 收藏搞代码吧

在Linux下开发 flutter linu下桌面应用 编译时遇到 cmake 链接不了ninja ,这个错误其实很简单,它的提示也有说解决方法

linux 海叔叔 4小时前 12次浏览 已收录 0个评论

在Linux下开发 flutter linu下桌面应用 编译时遇到 cmake 链接不了ninja ,这个错误其实很简单,它的提示也有说解决方法:

原句:CMake Error: CMake was unable to find a build program corresponding to “Ninja“. CM

1.我们根据他的提示https://github.com/ninja-build/ninja 这个地址的github clone 下来编译安装就可以了

他的项目README.md有说明.

如果你的Linux是unbuntn的应该软件仓库有包,apt 就可以了;

如果你是跟我一样archlinux 需要手动

sudo cp ./ninja /usr/bin
就可以了!

然后再次编译就应该没有问题了

如果你是其他错误可以看一下flutte依赖缺不缺


喜欢 (0)
[搞代码]
分享 (0)
发表我的评论
取消评论

表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址