• 欢迎访问搞代码网站,推荐使用最新版火狐浏览器和Chrome浏览器访问本网站!
  • 如果您觉得本站非常有看点,那么赶紧使用Ctrl+D 收藏搞代码吧

apache搭建与php版本的选择_php

php 搞代码 3年前 (2018-06-21) 106次浏览 已收录 0个评论

LAMP环境搭建是web开发非常流行的一个框架,但是版本的对应选择对于配置很重要,今天在网上查了相关资料,做一些有关apache版本和php版本的说明。

首先,apache现在主流的两个版本是2.2和2.4,功能区别就不多说了,主要说下和php的搭配。对于apache2.2可以和php5.3.x和php5.4.x的版本搭配,在选择php使用时,一定注意所下载的php目录中一定有“php5apache2_2.dll”文件,因为在配置apache的”Apache2.2/conf/httpd.conf”文件中的LoadModule时“LoadModule php5_module “c:/php/php5apache2_2.dll” ”一定是php5apache2_2.dll,否则会出现“the requested operation has failed!”的错误。对于apache2.4同理,只是“LoadModule php5_module “c:/php/php5apache2_4.dll”中用的是2_4。

下面说下php版本,下载地址http://windows.php.net/download/,大家下载时可能发现有nts版本和ts版本,比如:

  VC9 x86 Non Thread Safe    VC9 x86 Thread Safe 
  这两个有何区别,简单来说non-thread-safe 非 线程安全 与IIS 搭配环境,thread-safe  线程安全  与apache 搭配的 环境这个大家一定要注意,否则用错了版本,apache是无法启动的,另外在以后扩展库的下载也是有nts与ts不同的版本下载是要对应。
 另外,php5.5.x版本只能和apache2.4搭配,已经不支持2.2需要大家注意

欢迎大家阅读《apache搭建与php版本的选择_php》,跪求各位点评,若觉得好的话请收藏本文,by 搞代码


喜欢 (0)
[搞代码]
分享 (0)
发表我的评论
取消评论

表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址